Activities

January 2014
M T W T F S S
« Dec   Feb »
 12345
6789101112
13141516171819
20212223242526
2728293031  

How do I enable php-pspell extension and verify the install

One of the today’s interesting job is to assit an installation, as one of he DevOPs asked me to enable pspell library support in php. I just imply installed the it using yum command and had verified that it was enabled. But the dev. is unhappy on my approach. So I had to keep both of my eyes on it to learn his understanding..

[root@host28 ~]# yum install php-pspell
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-pspell.x86_64 0:5.3.3-27.el6_5 will be installed
--> Finished Dependency Resolution
Dependencies Resolved
================================================================================
 Package            Arch           Version                Repository       Size
================================================================================
Installing:
 php-pspell         x86_64         5.3.3-27.el6_5         updates          29 k
Transaction Summary
================================================================================
Install       1 Package(s)
Total download size: 29 k
Installed size: 21 k
Is this ok [y/N]:

Simple ! It is installed !!

How do I verify the installation

[root@host28 ~]# php -m | grep "pspell"
pspell
[root@host28 ~]# service httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]
[root@host28 ~]#

How do I test it is properly installed and work with php library.

You can verify the spell is properly linked with system dictionary by xecuting this command ‘aspell dump dicts“. If you can not see anything as command output, you may need to install “aspell-en” package to get english language support.

[root@host28 ~]# yum install aspell-en
[root@host28 ~]# aspell dump dicts
en
en-variant_0
en-variant_1
en-variant_2
en-w_accents
en-wo_accents
en_CA
en_CA-w_accents
en_CA-wo_accents
en_GB
en_GB-ise
en_GB-ise-w_accents
en_GB-ise-wo_accents
en_GB-ize
en_US
en_US-w_accents
en_US-wo_accents
[root@host28 ~]#

The following piece of php code help you to verify the same over the Apache

Looks interesting !! Yeah 🙂 If you feel something interesting really … that should work then !!! 🙂

2 comments to How do I enable php-pspell extension and verify the install

Leave a Reply

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>