Activities

June 2014
M T W T F S S
« Feb   Jul »
 1
2345678
9101112131415
16171819202122
23242526272829
30  

configure: error: C compiler cannot create executables

While I’m installing nagios 1.4.14 version on a new server, I got the following errors,

[root@fc-db02 nagios-plugins-1.4.14]# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.

After few minutes of Google, I found lots of threads having the same issue. I tried lots of options to install gcc, gc++ and kernel devel packages etc. But none of my efforts help me.

 yum install gcc
yum install gcc glibc glibc-common
 yum install  gcc-c++
 yum install gcc gcc-c++ kernel-devel
 yum groupinstall "Development Tools"

Finally I try to install Glibc headers which I found working great ! 🙂

[root@fc-db02 nagios-plugins-1.4.14]# yum install glibc*
Dependencies Resolved
====================================================================================================================================================================
 Package                             Arch                           Version                                      Repository                                    Size
====================================================================================================================================================================
Installing:
 glibc-devel                         x86_64                         2.12-1.132.el6_5.2                           rhel-x86_64-server-6                         978 k
 glibc-utils                         x86_64                         2.12-1.132.el6_5.2                           rhel-x86_64-server-6                         163 k
Installing for dependencies:
 gd                                  x86_64                         2.0.35-11.el6                                rhel-x86_64-server-6                         142 k
 libXpm                              x86_64                         3.5.10-2.el6                                 rhel-x86_64-server-6                          51 k
Transaction Summary
====================================================================================================================================================================
Install       4 Package(s)
Total download size: 1.3 M
Installed size: 0
Is this ok [y/N]: y
Downloading Packages:

Leave a Reply

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>