Activities

July 2015
M T W T F S S
« Jun   Aug »
 12345
6789101112
13141516171819
20212223242526
2728293031  

How do I upgrade the Ghostscript to the latest in Amazon EC2

The default GhostScript version which come up with Amazon EC2 was 8.6 and certain functionalities will not work on it. So I got a request to up-grade the version to 9.16 which is the latest march 2015 build. Installation is pretty simple. You may follow the below command execution to get it,

[root@Web01 ~]#wget http://downloads.ghostscript.com/public/ghostscript-9.16.tar.gz
[root@Web01 ~]#tar -zxvf ghostscript-9.16.tar.gz
[root@Web01 ~]#cd ghostscript-9.16
[root@Web01 ~]#./configure --prefix=/usr  --enable-dynamic   --disable-compile-inits --with-system-libtiff
[root@Web01 ~]#make
[root@Web01 ~]#make so
[root@Web01 ~]#make install
[root@Web01 ~]#make soinstall && install -v -m644 base/*.h /usr/include/ghostscript && ln -v -s ghostscript /usr/include/ps
[root@Web01 ~]#ln -sfv ../ghostscript/9.14/doc /usr/share/doc/ghostscript-9.14
[root@Web01 ~]#cd ..
[root@Web01 ~]#wget http://sourceforge.net/projects/gs-fonts/files/latest/download?source=files
[root@Web01 ~]#tar -xvf ghostscript-fonts-std-8.11.tar.gz -C /usr/share/ghostscript
[root@Web01 ~]#fc-cache -v /usr/share/ghostscript/fonts/
[root@Web01 ~]#ghostscript -v
[root@Web0 ~]# gs -v
GPL Ghostscript 9.16 (2015-03-30)
Copyright (C) 2015 Artifex Software, Inc.  All rights reserved.
[root@Web0 ~]#

Leave a Reply

  

  

  

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>